エンコーディング
データのエンコードとデコード:Base64、Base32、Base58、URL、HTML エンティティ、16 進数、Unicode など
エンコードはデータの表現形式を変えるだけで、誰が読めるかを変えるものではありません。Base64、Base32、Base58、16 進数、URL エンコードと HTML エンティティ、モールス信号、Punycode、quoted-printable などに対応しています。バイナリデータをテキストに埋め込む、安全な URL を組み立てる、JavaScript・CSS・シェルスクリプト用に文字列をエスケープする、といった用途に使えます。エンコードは暗号化ではないため、誰でも元に戻せます。
このカテゴリのツール数:26
まずはここから
このカテゴリのすべてのツール
-
Base64 デコード
Base64 や base64url を読める UTF-8 テキストにデコードし、生のバイト列を 16 進で表示することもできます。パディングなし、空白、data: URI 接頭辞にも対応。
-
Base64 エンコード
テキストや 16 進バイトをブラウザー内で Base64 にエンコードします。絵文字や日本語を含む UTF-8、URL セーフ、パディングの有無、76 文字折り返しに対応。
-
ASCII 表
10 進、16 進、8 進、2 進、文字、HTML コード、説明を備えた完全な ASCII 表(0〜127)です。文字、数値(0x41、0b…)、名前で検索できます。
-
Base32 デコード
Base32 や base32hex を UTF-8 テキストまたは 16 進バイトにデコードします。大文字小文字を区別せず、パディングは任意、空白は無視。TOTP のシークレットの確認に便利です。
-
Base32 エンコード
テキストや 16 進バイトを標準の A–Z2–7 アルファベットまたは base32hex で Base32(RFC 4648)にエンコードします。UTF-8 対応、パディング任意、ブラウザー内で動作。
-
Base58 デコード
Bitcoin のアルファベットの Base58 を UTF-8 テキストまたは 16 進バイトにデコードし、先頭のゼロバイトも保持します。0、O、I、l など無効な文字は明確なエラーで表示。
-
Base58 エンコード
テキストや 16 進バイトを Bitcoin のアルファベットで Base58 にエンコードします。先頭のゼロバイトは 1 になり、紛らわしい 0/O/I/l は使いません。無料・ブラウザー内。
-
Base64 ファイルのデコード
Base64 や data: URI を貼り付けて元のファイルをダウンロードします。マジックバイトから形式(PNG、JPEG、PDF、ZIP、JSON など)を判定し、画像はプレビュー表示します。
-
Base64 ファイルのエンコード
画像、PDF、あらゆるファイルを Base64 や data: URI に、アップロードなしでブラウザー内で変換します。URL セーフ、76 文字折り返し、コピーや .txt のダウンロードも可能。
-
CSS エスケープ
CSS の識別子やセレクター用に CSS.escape() と同じ方法でテキストをエスケープしたり、引用符付きの CSS 文字列用にエスケープしたりします。\HEX のアンエスケープにも対応。
-
エスケープ/アンエスケープ
JSON、JavaScript、HTML、XML、URL コンポーネント、正規表現、SQL リテラル、CSS 文字列、シェル引数向けに、文字列をエスケープ・アンエスケープできる 1 つのツールです。
-
16 進デコード
16 進バイトを UTF-8 テキストに戻します。スペース、コロン、カンマ、0x や \x の接頭辞に対応し、桁数が奇数の場合や無効な 16 進は明確に報告。無料・ブラウザー内。
-
16 進エンコード
テキストを UTF-8 バイトの 16 進数に変換します。大文字・小文字と、区切りなし・スペース・コロン・0x 接頭辞・\x エスケープを選択可能。ローカルで動作します。
-
HTML デコード
HTML エンティティをテキストにデコードします。HTML5 の名前付き参照 2,125 個すべて、10 進・16 進の数値参照、セミコロンなしの旧来の名前に対応。ブラウザー内で動作。
-
HTML エンコード
テキストを HTML 用にエスケープします。& < > " ' をエンティティにし、非 ASCII 文字も名前付き・10 進・16 進で変換可能。マークアップの崩れを防ぎ、ローカルで動作。
-
JavaScript エスケープ
JavaScript の文字列リテラル("…"、'…'、`…`)用に、\n、\t、\" や任意の非 ASCII 用 \uXXXX でテキストをエスケープし、JS の文字列をテキストに戻します。
-
モールス信号デコーダー
モールス符号をテキストにデコードします。. と -(· • − _ も可)、文字間のスペース、単語間の /・|・スペース 3 つに対応。未知の符号は明示されます。
-
モールス信号エンコーダー
テキストを国際モールス符号(ITU)に変換します。文字、数字、記号に対応し、単語は「 / 」で区切り、アクセントは自動で除去。すぐに使える無料ツールです。
-
Punycode 変換
国際化ドメイン名(IDN)を Punycode の xn-- ラベルに、またその逆に変換します。RFC 3492 の生の文字列のエンコードにも対応。1 行に 1 ドメイン、オフラインで動作。
-
Quoted-Printable
RFC 2045 に従い、メールの quoted-printable テキストをエンコード・デコードします。=XX エスケープ、76 文字のソフト改行、UTF-8 や ISO-8859-1 の文字セットに対応。
-
ROT13 エンコーダー
テキストに ROT13、または ROT5(数字)、ROT18(英字と数字)、ROT47(印字可能な ASCII 全体)を適用します。2 回適用すると元に戻ります。無料ですぐに使えます。
-
シェルエスケープ
POSIX sh/Bash/Zsh(シングルクォート)、Bash の ANSI-C $'…'、PowerShell 向けに文字列を安全に引用符で囲み、引用符付きのシェルの単語を元の値に戻すこともできます。
-
Unicode 変換
テキストを Unicode コードポイント(U+XXXX)、サロゲートペアの JavaScript \u エスケープ、ES6 \u{}、Python、HTML &#x;、CSS のエスケープに相互変換します。
-
Unicode 検索
任意の文字を調べます。Unicode の正式名称、U+ コードポイント、カテゴリ、面、UTF-8/UTF-16 のバイト列、HTML・JS・CSS・URL のエスケープを表示し、名前での検索も可能。
-
URL デコード
%XX のパーセントエンコードを読める UTF-8 テキストに戻します。クエリ文字列用に + をスペースにするオプションあり。不正な並びは失われず、保持して報告します。
-
URL エンコード
URL 用にテキストをパーセントエンコードします。encodeURIComponent、厳密な RFC 3986、URL 全体(encodeURI)、スペースを + にするフォームデータに対応。UTF-8 対応。
その他のカテゴリ
- CRC エラー検出のための巡回冗長検査アルゴリズム
- MD メッセージダイジェストアルゴリズム(MD2、MD4、MD5)
- SHA-1 セキュアハッシュアルゴリズム1 - 160ビットハッシュ関数
- SHA-2 セキュアハッシュアルゴリズム2ファミリー(SHA-224、SHA-256、SHA-384、SHA-512)
- SHA-3 Keccakベースのセキュアハッシュアルゴリズム3
- Keccak Keccak暗号化ハッシュ関数
- SHAKE 拡張可能出力関数(SHAKE128、SHAKE256)
- cSHAKE カスタマイズ可能なSHAKE関数
- KMAC Keccakメッセージ認証コード
- パスワードとセキュリティ パスワード生成、分析、ハッシュ化、セキュリティツール
- 暗号化 共通鍵・公開鍵暗号、HMAC、鍵生成(AES、3DES、RSA、PGP)
- フォーマッター コードとデータの整形・圧縮・検証(JSON、XML、YAML、SQL、HTML、CSS)と命名スタイルの変換
- ジェネレーター ID、キー、テストデータ、QR コード、バーコード、設定ファイルを生成(UUID、API キー、.gitignore、Dockerfile)
- コンバーター データ形式、進数、色、タイムスタンプ、単位、通貨の変換(JSON、CSV、YAML、XML)
- テキストツール テキストのカウント・比較・整形・変換(文字数、差分、正規表現、大文字小文字、重複削除)
- 画像ツール 画像を操作および変換するためのツール(圧縮、サイズ変更、変換)
- デザインとCSS CSS を視覚的に生成:シャドウ、グラデーション、Flexbox・Grid レイアウト、アニメーション、カラーパレット
- Webツール Web 開発と SEO のためのツール(JWT、URL、DNS、HTTP ヘッダー、meta タグ、サイトマップ)
- 数学・計算ツール お金、健康、パーセント、プログラマー向け計算、日常の数学のための計算ツール
- 時間と日付 タイムゾーン、日付の差、営業日、タイマー、ストップウォッチ、世界時計